Degraded Performance: Cloudhawk Portal Live Map

Incident Report for BrightOrder

Monitoring

We have identified and resolved the issue impacting trackers. The disruption was related to an infrastructure partner’s maintenance window, which temporarily affected our ability to process tracker data.

We are actively monitoring the system as tracker data returns to normal and expect service to be fully restored within the next hour. We do not expect any loss of historical tracker data.
Posted May 18, 2026 - 19:41 EDT

Investigating

We are currently investigating a system-wide issue impacting trackers. Users may be experiencing delayed or unavailable tracker data across the platform.

Our team is actively working to identify the cause and restore normal service as quickly as possible. We apologize for the inconvenience and will provide updates as more information becomes available.
Posted May 18, 2026 - 17:56 EDT
This incident affects: Telematics (CloudHawk Customer Portal).