Customers may be unable to access the EMDECS Fleet Maintenace System (KONA).

Incident Report for BrightOrder

Resolved

The previously reported interruption affecting EMDECS Kona (EC, NA, and EU) systems has been fully resolved.

We will continue to monitor system performance closely over the next several hours to ensure continued stability.
Posted Mar 10, 2026 - 08:05 EDT

Investigating

We are currently investigating a critical service interruption affecting our EMDECS Kona systems across the EC, NA, and EU databases. Our monitoring systems flagged a significant spike in latency and connectivity failures

Users in these regions may experience timeouts, inability to log in, or intermittent connectivity when accessing the system. We're currently investigating the issue and will continue to update you as we learn more.
Posted Mar 10, 2026 - 07:26 EDT
This incident affected: EMDECS (EMDECS Web Solution).