Users may experience slowness when accessing and using EMDECS (EC)
Incident Report for BrightOrder Inc
Resolved
This incident has been resolved. If you are still experiencing performance issues please contact the CX team at 1-877-848-8817 or submit a ticket at http://help.emdecs.com/
Posted Apr 11, 2023 - 20:01 EDT
Identified
We have identified the source of intermittent slowness for customers. A resolution will be applied this evening by our IT team.
Posted Apr 11, 2023 - 15:00 EDT
Investigating
EMDECS users who access the EMDECS Fleet Maintenance system from North America & Europe are experiencing performance issues within the EMDECS system. This is affecting users using https://www.emdecs.com/kona.

We are investigating the cause of the service disruption.
Posted Apr 11, 2023 - 12:41 EDT
This incident affected: Generation 2 (EMDECS Kona) Application.