Some customers may experience slowness when accessing Emdecs
Incident Report for BrightOrder Inc
Resolved
This incident has been resolved. If you are still experiencing performance issues please contact the CX team at 1-877-848-8817 or submit a ticket at http://help.emdecs.com/
Posted Jan 19, 2023 - 08:03 EST
Investigating
Some customers may be experiencing slowness when accessing Emdecs, we are aware of this issue and are investigating the cause.
Posted Jan 18, 2023 - 12:54 EST
This incident affected: Generation 2 (EMDECS Kona) Application.