Some customers may experience slowness when accessing Emdecs
Incident Report for BrightOrder Inc
Resolved
This incident has been resolved. If you are still experiencing performance issues please contact the CX team at 1-877-848-8817
Posted Jan 16, 2023 - 17:48 EST
Identified
Some customers may be experiencing slowness and working please wait messages while accessing Emdecs, we are aware of the issue and working to correct this.
Posted Jan 16, 2023 - 16:17 EST
This incident affected: Generation 2 (EMDECS Kona) Application.