Customers are experiencing slowness accessing EMDECS and loading screens in the system
Incident Report for BrightOrder Inc
Resolved
System performance has returned back to normal. Thank you for your patience.
Posted Aug 15, 2019 - 17:07 EDT
Investigating
Customers are currently experiencing slowness when trying to access or use the EMDECS system. Our team are investigating the source of the problem. We apologize for this inconvenience.
Posted Aug 15, 2019 - 16:53 EDT
This incident affected: Generation 1 (EMDECS Forms) Application and Generation 2 (EMDECS Kona) Application.