EMDECS Users may have difficulty calling the BrightOrder Support Line.
Incident Report for BrightOrder Inc
Resolved
Our phone system is back online. Customers can contact us by phone as normal. Thank you for your patience!
Posted Mar 15, 2024 - 10:01 EDT
Update
Our phone system provider is experiencing a widespread outage and we are waiting for updates. As a result, our agents are unable to sign in to our phone queue and customer calls may be rejected or dropped. We apologize for this inconvenience.

For urgent issues, please contact us using the live chat icon located at the bottom-right hand corner of our help website at https://knowledge.brightorder.com/

Non-urgent issues can be sent to us by email at help@brightorder.com or submitted online at https://knowledge.brightorder.com/kb-tickets/new
Posted Mar 15, 2024 - 09:22 EDT
Identified
EMDECS users are unable to call our Support Line at this time due to external issues.
The issue has been identified and we are currently waiting on a resolution.
Posted Mar 15, 2024 - 09:10 EDT
Investigating
EMDECS users are unable to call our Support Line at this time due to external issues.
We're currently investigating the cause of the mobile support line disruption.
Posted Mar 15, 2024 - 08:50 EDT
This incident affected: BrightOrder Support Phone.