Some customers may experience slowness or be disconnected when accessing EMDECS
Incident Report for BrightOrder Inc
Resolved
This incident has been resolved. If you are still experiencing performance issues please contact the CX team at 1-877-848-8817 or submit a ticket at http://help.emdecs.com/
Posted Jan 20, 2023 - 22:07 EST
Investigating
We are currently investigating this issue. Thank you for your patience.
Posted Jan 20, 2023 - 10:02 EST
This incident affected: Generation 2 (EMDECS Kona) Application.