Some customers may experience slowness when accessing Emdecs
Incident Report for BrightOrder Inc
Resolved
This incident has been resolved.
Posted Jan 16, 2023 - 13:51 EST
Investigating
Some customers may experience slowness when accessing Emdecs using https://www.emdecs.com/kona

We are currently investigating.
Posted Jan 16, 2023 - 12:01 EST
This incident affected: Generation 2 (EMDECS Kona) Application.