Users are unable to access EMDECS
Incident Report for BrightOrder Inc
Resolved
Our IT team has restarted our servers and users are able to sign in to EMDECS again. If you experience any problems accessing EMDECS, please try clearing temporary Internet files and try again. Please contact our customer experience team at help@brightorder.com or at 1-877-205-8817 if problems persist.

Thank you for your patience and again we apologize for the disruption in your work day.
Posted Dec 23, 2019 - 10:32 EST
Update
Our IT team is continuing to work on resolving issues with being unable to access EMDECS. We apologize for the inconvenience and we appreciate your patience. We will continue to provide updates until the issue has been resolved.
Posted Dec 23, 2019 - 10:19 EST
Investigating
Users are currently unable to access EMDECS. The log in page is hanging. Our IT team is investigating the cause of the problem.
Posted Dec 23, 2019 - 09:49 EST
This incident affected: Generation 1 (EMDECS Forms) Application, Generation 1 (EMDECS Forms) Printing Services, Generation 2 (EMDECS Kona) Application, and Generation 2 (EMDECS Kona) Printing Services.