Users are Unable to Access EMDECS
Incident Report for BrightOrder Inc
Resolved
Users are able to sign in to EMDECS again. Thank you for your patience while our team resolved the sign in issue.
Posted Aug 03, 2019 - 23:08 EDT
Identified
Users are currently unable to access EMDECS. Our IT team is aware of the problem and is working to restore services as soon as possible. We apologize for the inconvenience.
Posted Aug 03, 2019 - 20:38 EDT
This incident affected: Generation 1 (EMDECS Forms) Application, Generation 1 (EMDECS Forms) Printing Services, Generation 2 (EMDECS Kona) Application, and Generation 2 (EMDECS Kona) Printing Services.