EMDECS users are unable to print invoices or reports.
Incident Report for BrightOrder Inc
Resolved
All invoice and report printing in the EMDECS Fleet Maintenance System has been restored.

Thank you for your patience and understanding during this unplanned system downtime.

If you continue to experience any issues with printing, please submit a support request with our customer experience team online at: http://support.emdecs.com
Posted Dec 24, 2019 - 12:21 EST
Investigating
EMDECS users are unable to print invoices or reports from the EMDECS Fleet Maintenance System.

Our IT team is investigating the cause of the printing service disruption.
Posted Dec 24, 2019 - 11:53 EST
This incident affected: Generation 1 (EMDECS Forms) Printing Services.