Customers are unable to sign into EMDECS
Incident Report for BrightOrder Inc
Resolved
This incident has been resolved.
Posted Jan 27, 2020 - 12:27 EST
Update
Access to the EMDECS Fleet Maintenance System (Gen 1 & Gen 2) has been restored. All users are able to sign in again.

Thank you for your patience and understanding during this unplanned system downtime.

If you continue to experience any issues accessing EMDECS, please submit a support request with our customer experience team online at: http://support.emdecs.com
Posted Jan 27, 2020 - 12:26 EST
Update
We are continuing to investigate this issue.
Posted Jan 27, 2020 - 09:08 EST
Investigating
We are currently investigating the issue.
Posted Jan 27, 2020 - 08:27 EST
This incident affected: Generation 1 (EMDECS Forms) Application, Generation 1 (EMDECS Forms) Printing Services, Generation 2 (EMDECS Kona) Application, and Generation 2 (EMDECS Kona) Printing Services.