EMDECS Performance issues
Incident Report for BrightOrder Inc
Resolved
This incident has been resolved.
Posted Jun 29, 2020 - 12:53 EDT
Identified
IT is aware of the issue and working on it.
Posted Jun 29, 2020 - 11:16 EDT
This incident affected: Generation 2 (EMDECS Kona) Application and Generation 2 (EMDECS Kona) Printing Services.