Some customers may experience slowness when accessing Emdecs
Incident Report for BrightOrder Inc
Resolved
This incident has been resolved. If you are still experiencing performance issues please contact the CX team at 1-877-848-8817 or submit a ticket at http://help.emdecs.com/
Posted Jun 20, 2023 - 20:02 EDT
Monitoring
This issue has been tested and the performance issues appear to be gone. We are continuing to monitor the situation, thank you for your patience. If you are still experiencing performance issues please contact the Customer Experience team at 1-877-848-8817 or submit a ticket at http://help.emdecs.com/
Posted Jun 20, 2023 - 19:13 EDT
Investigating
Some users may be experiencing slowness when accessing EMDECS, we are aware of this issue and are investigating.
Thank you for your patience.
Posted Jun 20, 2023 - 13:29 EDT
This incident affected: Generation 2 (EMDECS Kona) Application.