EMDECS users are experiencing system slowness.
Incident Report for BrightOrder Inc
Resolved
The performance of the EMDECS Fleet Maintenance System has returned to normal.

Thank you for your patience and understanding.

If you continue to experience any issues with performance, please contact our customer experience team at 1-888-205-8817 (option 1) or email help@brightorder.com.
Posted Jan 30, 2024 - 08:54 EST
Monitoring
We are continuing to work on resolving system performance issues in EMDECS.

We apologize for the ongoing service disruption and appreciate your patience. All efforts are being made to resolve the issue as soon as possible.
Posted Jan 30, 2024 - 08:28 EST
Investigating
EMDECS users may be experiencing slowness signing into or entering data into the EMDECS Fleet Maintenance System.

We are investigating the cause of the system slow downs.
Posted Jan 30, 2024 - 07:35 EST
This incident affected: Generation 2 (EMDECS Kona) Application.